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1 Introduction 
 
Thank you for choosing GeoMil Equipment’s CPTask presentation software. 

 

CPTask is a Microsoft Windows based CPT data processing, interpretation and presentation software 

for all your CPT related office tasks. CPTask offer a user-friendly, mouse driven, working 

environment by providing a simple graphical user interface. Some key features offered by CPTask 

1.15 are: 

 

� Working both on individual files as well as on a project basis 

� Simple editing of both signal and header data 

� Creation and importing new CPT files 

� Export of CPT files to a wide array of output formats 

� A high level of control regarding the appearance of plotted signals 

� Multilingual 

� Customizable plot translations 

 

Updated version of CPTask can be download from the GeoMil website www.geomil.nl 

 

!! Note that a HASP key is required to use CPTask. 

 

1.1 Organization of the user manual 
 

The purpose of this manual is to provide both a introduction to CPTask for new users, as well as a 

reference for those people who use CPTask regular.  

 

We start of with a short tutorial of CPTask, explaining the installation process and globally discussing 

various aspects of CPTask. Chapter 2, 3, and 5 discuss the process of working with files, projects and 

dissipation files. Chapter 4 deals with the exporting of files to various output formats. Next, chapter 6 

discusses ways of editing both signal data and header data. Chapter 7 and 8 discuss the extensive 

collection of both file specific and application wide options available in CPTask. In Chapter 9 we 

discuss the customization of the plot language by creating our own translation. Finally, appendix A 

and B contain the formulas used for deriving useful signals and a comprehensive overview of the 

CPTask menu structure respectively.  
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1.2 Installing CPTask 
 

The installation package of CPTask should, besides this manual which you’ve obviously received, 

contain the following items: 

 

� The CPTask installation CD 

� a HASP key 

 

After inserting the CPTask installation CD into your computer, open its contents using the Windows 

explorer. Click on the “SetupShell” icon to initialize the CPTask installation procedure. Besides 

installing the CPTask software this program will also install the drivers required for using the HASP 

key. 

 

 
The CPTask installation screen 

 

If either the HASP drivers or the CPTask software is already installed on your system, the installation 

procedure will explicitly ask if you wish to re-install the software. 

 

To install the HASP drivers click on the “Install Hasp Driver” button in the setup screen. 

 

To install the CPTask software click on the “Install CPTask” button in the setup screen. 

If CPTask is not yet installed on you system, the installation procedure will ask for a target directory 

in which the CPTask software will be installed. 

 

If the CPTask software is already installed on your system, the installation procedure will offer you 

the possibility to repair or un-install the installed software. 
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1.3 The CPTask user interface 

 
If you start CPTask you will find the menu bar on the top of your screen. Directly below the main 

menu bar is another menu bar which contains shortcut buttons to various operations. On the bottom of 

the screen you can see a status bar which notifies you about events happening in CPTask. 

 

 
Screenshot of CPTask user interface 

 
Clicking on the various items in the main menu will redirect you to one of the sub menu’s. 

The total menu structure of CPTask can be found in one comprehensive overview in Appendix B. 
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1.4 Supported file formats 

 

CPTask support two sorts of input file formats. 

1.4.1 GME files 

 
GME is a file standard which was used in outdated measuring systems. However, this file format is 

still used since it allows the raw data to be saved instantaneously, thereby dealing effectively with 

things as power failure during CPT Tests. 

 

The data in the (old) GME data format is stored in two files. 

The first file is named ***.0** (header) and the second file is named ***.1** (data). 

Additional dissipation tests are stored as ***.D** files. 

1.4.2 GEF files 

 
Gef (Geotechnical Exchange Format) is a general language structure for storing and transferring 

geotechnical information. The Gef data format is stored in just one file. This file type has the 

extension *.Gef. Additional dissipation tests are stored under the same file name as the Gef file but 

with an additional suffix. These files are referenced by the original Gef file. 

 

A more specific explanation about the Gef-standard can be found at www.geonet.nl 

(http://www.geonet.nl/3.020.html). 

 

Once a file is opened it can be saved to the Gef file format or exported to various output format. For a 

detailed description of file exporting (see chapter 4). 

 

CPTask does not change the opened files and a backup of the original files are always kept in the 

directory containing the opened file. 
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1.5 CPTask presentation standards 

 
CPTask provides two main ways of presenting your data. First, there is the Dutch standard which can 

show multiple graphs on one page. Secondly, there is the international standard which allows dynamic 

control over the way the various signals are displayed on the plot. Switching between both plot 

standards can be done in the settings screen (see chapter 8.3). 

1.5.1 Dutch standard 

 
The Dutch standard is a static plot method. It is possible to display up to three graphs on one page. 

There can be two graphs at the left side of the plot. At the right of the screen it is only possible to print 

one graph. The horizontal scale of this right graph is reversed. Every graph has it's own horizontal 

scale that can be customized (see chapter 8.2).  
 

 
Example of a Dutch standard plot 
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1.5.2 International Standard 

 
The international standard is a very flexible way of displaying different signals in one plot.  

Graphs plotted with the international standard can be printed both in landscape or portrait orientation. 

It is also possible to choose the order, the width and the height of the displayed graphs (see chapter 7 

and 8). 

 

 

 
Example of a international standard plot 
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2 Working with files 
 
CPTask offers flexible ways to create your own new soundings, as well as opening existing sounding 

files obtained from the field. Regardless of the way the data is obtained, it can be saved / exported to 

various forms of output. 

2.1 Creating new CPT files manually 

 
CPTask offers the option to manually create new sounding files which can be fully customized. To 

create a empty sounding use the menu option: 

 

File → Create → Create CPT 

 

The following information is required to successfully instantiate a new sounding: 

 

� The filename of the sounding file 

� The total penetration length of the sounding 

� The sample interval 

 

After a new sounding is created the header data can be customized in the header tab (see chapter 6.2). 

The actual sounding data can specified in at the data editing screen (see chapter 6.1). 

 

 
A empty sounding ready to be edited 
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2.2 Importing Files 

 
Besides manually creating a new sounding file from scratch, CPTask offers the possibility to import a 

Microsoft Excel file in which all necessary values are specified. Since Microsoft Excel offers various 

ways of efficiently manipulating large quantities of data, this method is exceptionally useful for 

importing new data into CPTask. 

2.2.1 Import from Excel templates 
 

The import of data is possible using the Microsoft Excel templates which comes with CPTask. 

Both header data and raw sounding data can be imported simultaneously. 

The accompanied Excel templates consist of two Excel worksheets, one titled header the other titled 

data. The following header data can be supplied at the header worksheet. 

 

� Client Name 

� Task Number 

� Sounding Number 

� Cone Number 

� Location 

� Operator 

� Date 

� Starting Time 

� Penetration Time 

� Stopping Time 

� Water Level 

� Reference Level 

� Ground Level 

� Predrilled Depth 

� Penetration Depth    Selecting signals to import 

� Remark(s) 

 

If no value is filled in the imported value will be empty. Of course the corresponding values can 

always be filled in after the import process is completed. 

The selected signal types needs to be filled in a the data worksheet in the following order: 

 

depth,[qc,fs,u,I,Qst,Qt] 

 

After the “import from Excel” option is selected in the file menu, the Excel file to import and the 

output filename can be specified. Finally the signals which need to be imported need to be specified. 

 

CPTask comes complete with different Microsoft Excel templates which are already formatted to the 

prescribed data format. The templates are available in various languages and can be found in the 

\CPTask\Excel Template directory. 
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2.3 Opening existing files 

 
Opening existing files can be done by selecting the menu option 

 

File → Open CPT (Shortcut Ctrl-O) 

 

The shortcut menu bar below the main menu also contains a short cut button to open files. 

 

 
Filtering the files to open 

 

When opening files you can select to filter the files shown in the dialog box by selecting one of the 

supported extensions. This will result in CPTask showing the selected file type exclusively. 

2.4 Filtering sounding files 
 

When opening files in CPTask the data is automatically filtered. Default settings for filtering can be 

set in the settings screen (see chapter 8.3). After opening files it is still possible to filter signals 

additional times. By filtering peak signals can be significantly smoothened by taking the average of a 

certain interval of values around a value. If filtering is applied several times the smoothening effect is 

even stronger. 

 

Opened files can be filtered by using the menu option 

 

Edit → Filter  
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Filtering signals 

 

The filter factor is the number of times the filter is executed. The signals to filter can be specified by 

checking them. Specified filters can be applied to single files or to all files by clicking on “Filter 

single” or “Filter all” respectively. With “Reset initial value's” the values from the CPT file are 

loaded again. 
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3 Working with projects 

 
In CPTask, projects are sounding files belonging to the same sounding session. All these files have the 

same project identifier in the Gef header data. CPTask offers the possibility to work with whole 

projects at the same time. Projects can be opened simultaneously and various header settings can be 

changed on a project basis. 

3.1 Loading projects to your project directory 

 
Project files can be loaded into the project directory by using menu option: 

 

File → Load Project(s)  Shortcut (Ctrl-L) 

 

 
Loading project into the project directory 

 

By selecting the “Open location” button a source directory can be selected. After selecting the source 

directory CPTask will scan this directory and show all available projects in that directory. Besides the 

project names, the number of files belonging to the project will be shown together with the path of the 

project files. By selecting the projects and clicking on the “Load files to project directory” the 

selected project will be copied to the project directory. For more information about the project 

directory and how it can be adjusted see chapter 8.3. 
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3.2 Opening projects 

 
Whole projects can be opened at once by using the menu option: 

 

File → Open Project →Scan all project folders 

 

 
Opening projects 

 

By selecting the project to open and clicking either “Open Gef-files” or “Open GME-files” 

(depending on the file type used) all files belonging to the project will be opened in CPTask. 

 

You can also open projects from a arbitrary directory by using the menu option: 

 

File → Open Project →Scan selected project folders 

 

After selecting a directory, all project residing in that directory can be opened in the same way as 

described above. 
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4 Exporting files 
 
Once a sounding file is opened in CPTask the contents of this file can be exported to various forms of 

output files. Export file types supported by CPTask are: 

 

� ASCII file format (both CPTask ASCII and iDat ASCII standards) 

� PDF file format 

� Microsoft Excel file format 

� DXF file format 

� Jpeg file format 

 

With all export functions a export file name and a directory have to be specified under which the 

exported files are stored. 

4.1 Exporting to ASCII file format 

 
To export the numerical data of the opened file you can choose to export it to the ASCII standard. The 

main advantage of this file type is that the size of the files are very small and the ASCII file type can 

be opened on every computer. 

 

To export an opened file to ASCII file format choose the menu options: 

 

File → Export → ASCII → Single → CPTask  to export the currently active sounding or 

File → Export → ASCII → Single → CPTask  to export all soundings currently opened in CPTask. 

 

Another ASCII file format to which soundings can be exported is the iDat format. This function 

exports the sounding data to a file which contains minimal header data followed by the data which is 

exported in a well defined order.  

 

To export an opened file to iDat ASCII file format choose the menu options: 

 

File → Export → ASCII → Single → iDat  to export the currently active sounding or 

File → Export → ASCII → Single → iDat   to export all soundings currently opened in CPTask. 

 

Both export file types can be read which a standard ASCII file reader (i.e. Notepad or Microsoft 

Word). 

 

!! Note that ASCII export gives no graphical representation of the data. 
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4.2 Exporting to PDF file format 
 

If you want to export the graphical representation of the data you can choose to export a opened 

sounding file to a PDF file. This effectively exports your graphs to a file format compatible with 

computers who have Adobe Acrobat Reader installed. This way you can send graphical representation 

of your data to people who don’t use CPTask. 

  

!!! Note that after export to PDF the exported file can not be changed. 

 

To export your file to PDF file format use the menu options: 

 

File → Export → PDF → Single   to export the currently active sounding or 

File → Export → PDF → All   to export all soundings currently opened in CPTask. 

4.3 Exporting to Microsoft Excel file format 
 

The Excel export function exports the numerical data of your sounding files to a Microsoft Excel file. 

This file type can only be read by Microsoft Excel (which is a component of the Microsoft Office 

Suite). Although exporting to Excel files requires more time and disc space than a ASCII export it can 

be useful if advanced handling of your sounding data is required. After exporting your data to Excel 

files it can be imported again into CPTask. For a description of Excel import see chapter 2.2. 

 

To export your file to Microsoft Excel file format use the menu options: 

 

File → Export → Excel → Single   to export the currently active sounding or 

File → Export → Excel → All    to export all soundings currently opened in CPTask. 

4.4 Exporting to DXF file format 
 

The DXF file format is a format which is compatible which various CAD applications (i.e. AutoCAD).  

Various applications support this file format. Although the data itself is numerical exported, numerous 

DXF viewers can create a graphical representation of the exported data. When exporting you need to 

specify the type of AutoCad file (AutoCad 14 or AutoCad 2000 or later). 

 

To export your file to DXF file format use the menu options: 

 

File → Export → DXF →Single   to export the currently active sounding. 

File → Export → DXF→ All   to export all soundings currently opened in CPTask. 

4.5 Exporting to Jpeg file format 
 

The Jpeg file format is a commonly used standard method of compression for photographic images. 

Exporting opened files will create a picture of the graphical representation of the data. The exported 

Jpeg file can be opened by almost all picture viewers as well as imported into a Microsoft Word 

document. 

 

To export your file to JPEG file format use the menu options: 

 

File → Export → JPG     to export the currently active sounding. 
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4.6 Exporting Dissipation tests 
 

Besides exporting basic sounding files, CPTask also offers a option to export dissipation tests. 

Dissipation tests can be exported to both ASCII and Microsoft Excel file formats. 

 

To export dissipations use the menu options: 

 

File → Export → Dissipation → ASCII  to export dissipation files to the ASCII file format or  

File → Export → Dissipation → Excel   to export dissipation files to the Excel file format. 

 

After choosing the export method, the dissipation tests you would like to export can be specified. Next 

you will have to specify a export directory to which the dissipation files are exported. 

The files are automatically given a suffix to distinguish them from each other after exporting. 

 

 
Selecting dissipations tests to export 
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5 Dissipation tests 
 
Since the Gef standard provides a flexible way to link dissipation tests to their corresponding sounding 

files, CPTask offers various ways to include these dissipation tests into your plots. 

 

If a Gef file contains dissipation tests, these are automatically opened in CPTask together with the 

original Gef file. By clicking on the Dissipation tab the various plots of the dissipation tests can be 

viewed. If a Gef file contains more then one dissipation test, switching between them can be done at 

the right side of the screen, where each dissipation test is characterized by the depth on which it was 

conducted. 

 

 
Viewing dissipation tests 

 

When working with GME files, CPTask offers a simple way to include additional dissipation tests into 

your sounding plot. If a GME file is opened, the “Add dissipation to sounding” button on the header 

tab allows you to add a dissipation test to your sounding file. Added dissipation tests become 

immediately available in CPTask.  

 

When saving a GME file to the Gef file format, the incorporated dissipation test are automatically 

linked to the Gef file. This way, when reopening the Gef file, the dissipation tests are also opened. 
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5.1 Dissipation options 

 
Dissipation plots can be customized to adjust them to your specific needs. This can be done on the 

“Diss. Settings” tab. All options can be set on a per dissipation basis, providing maximum flexibility.  

 

 
Customizing your dissipation plots 

 

The following options can be adjusted to customize your dissipation plots: 

 

� Color (switch between color plots and black / white plots ) 

� Include dissipation in Print/PDF (includes your dissipation plots in your print and export)  

� Parameter (switch available signals on / off in the plot) 

� Scale 

 
In this section both scales can be manually specified. The scale of the Dynamic pore pressure can be 

automatically calculated by checking the “Auto-calculate vertical scale u” checkbox. 

 

� Ui and U0 

 

Both the begin value of the Dynamic pore pressure and the u0 values can be changed.  By checking 

“Ui = Ubegin” and “U0 = calculated” both values will be directly derived from the dissipation data. 

By un checking them you are able to specify these values manually. 
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� Timelines 

 

You can specify two percentages of the active dissipation. These percentages will be explicitly shown 

in your dissipation plot. (i.e. you can specify 50 and 70. This way the time a dissipation is 50% 

complete and 70% complete will be shown explicitly in the plot.). 
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6 Editing files 
 
Although most properties of sounding files are specified in the field, CPTask offers ways to change 

practically all these properties. Both the obtained data values from the field as well as the header data 

containing information about the actual sounding, can be edited. 

6.1 Editing Data 

 
CPTask offers facilities to edit the original data you receive from the field and adjust it to your likings. 

You can edit the data in a opened file by selecting the “Data” tab on your sounding form.  If you right 

click on the shown data you can access the edit screen by clicking on “Edit data”. You can also use 

the button next to the shown data in the sounding form. 

 

 
Screenshot of CPTask data editing screen 

 

This editing screen can be fully operated using the mouse buttons. Various shortcut buttons reside on 

the top menu bar. 

 

Selecting data is done by using the left mouse button. Whole columns or rows can be selected by 

clicking on the fixed column / rows on the top / left of the edit screen. This way, whole columns or 

rows can be selected without dragging the mouse. 

 

Operations defined on the data are: 

 

� Deleting and inserting rows to remove / create new data 

� Mathematical operators like: addition, subtraction, multiplication and division 

� Linear interpolate a given range of values over a certain amount of selected rows 

 

Editing results can be made final by clicking on the “Save” button in the menu bar. 
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If you accidentally make a mistake during editing, the “Undo” button can be used to return to the 

previous state of your data. 

 

!! Note that you can only undo the last ten changes you made. 

6.2 Editing Header data 
 

Header data can be changed by clicking on the header tab of your sounding. All values, except for the 

penetration length, can be changed, and will be saved to either the GEF file or the CPTask settings 

file. 

 

The following general header data can be adjusted: 

 

� Project name 

� Project number 

� Client 

� Test number 

� Cone number 

� Location 

� Operator 

� Date 

� Start time 

 

 
Editing your header data 

 

The penetration length cannot be adjusted, but is directly derived from the actual number of data 

samples and the sample interval. This way no inconsistencies can occur between the actual depth and 

the specified penetration length. 
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Besides specifying general project data the following things can also be specified in the header tab: 

 

� Reference level 

� Coordinate system 

� North – South coordinates and East – West coordinates 

� Location of the pore pressure filter 

� Water level 

� Ground level 

� Timing properties 

� Cone area properties 

� Pre drill values 

� Pre drill text    (text to be displayed in a plot when pre drilling occurred) 

 

Finally, CPTask offers the possibility to define two user defined remarks which are displayed in the 

plots. You can specify the text to display as well as the coordinates to display the textbox. The 

coordinates are to be specified in depth (in m) and x coordinate (in cm) from the left of the plot. 

If the remark positions are not specified, the remark(s) will be plotted on the bottom of the plot. 

6.2.1 Editing multiple files at once 

 

When working with multiple files simultaneously or working with projects, header data can be 

changed for all opened files at the same time by clicking on the “Change for all open files” button in 

the header tab. 

 
Editing multiple files simultaneously 

 

Both general project data as well as various test variables can be specified and propagated to all 

opened files by using the associated “Change” buttons. 

6.3 Pasting sounding files 

 
Besides editing the data of a opened sounding file, it is also possible to paste another sounding at the 

end of a opened sounding. Doing this will basically result in the opened sounding extended with the 

data of the pasted sounding. The header data will remain that of the already opened sounding. Pasting 

sounding require caution, since pasting totally different soundings can result in unrealistic results.  

 

!! Pasting sounding files requires that both files contain exactly the same set of signals. 
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7 Settings the print parameters 
 

Besides working with physically measured variables, CPTask offers the possibility to derive a wide 

array of signals from these measured values. These derived signals can also be plotted in CPTask. 

Several calculations of these signals depend on both measured data and constants. The constant values 

used in these calculations can be adjusted in the “Settings/ Factors” menu (see chapter 8.3).  The 

equations used to calculate the derived signals can be found in Appendix A. 

 

Depending on the printing standard used, CPTask offers different ways to specify the signals to plot. 

By clicking on the “Parameter” tab on the sounding form you can specify the signals to plot. 

 

Both standards offer the possibility to propagate the parameter settings to all opened sounding files by 

clicking on the “Change for all open files” button on the bottom of the screen. 

7.1 Parameter settings in the Dutch standard 

 
Signals can be plotted by checking them in the “Parameter” tab. In the second column CPTask shows 

which signals are physically measured and which can be derived. If a checkbox next to a signals is 

inactive this means that this signal was not measured or cannot be derived from the measured signals.  

 

 
Settings signals to print in the Dutch standard 

 

By clicking on the “Select all” button all active signals will be selected. 

 

Note !!! In the Dutch standard, signals are automatically assigned a place in the plot. 
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7.2 Parameter settings in the international standard 
 

The international standard offers a more flexible way of specifying the manor in which the various 

signals are printed in the eventual plot. Up to eight pages of plots can be specified using the 

international standard. Additional pages can be added by clicking on the “Add page” button. By 

clicking on the “Remove page” button the last page will be removed. Both buttons reside on the top of 

the screen. 

 

 
Settings signals to print in the international standard 

 

Signals can be added to pages by selecting them in the left list and clicking on the “Add” button at the 

page you want the signal to be plotted. Removing signals from a particular pages is done by selecting 

the signal to remove and clicking on the “Remove” button corresponding to that page.  

 

On the bottom of the signal list, at the left side of the screen, two signal parameters (soillg & iclg) are 

available which do not correspond to concrete signals. These signals correspond to the legenda of the 

soil classification and the soil behaviour index respectively. These signals can be treated as regular 

signals and can therefore be added to the plot. 
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8 Customizing CPTask 
 
To allow for a more flexible way to display your plots, CPTask offers a extensive collection of options 

to customize your plots. Both the way your plots are printed as the scales used to plot your graphs can 

be customized in CPTask. Finally the options which are used to customize the whole application are 

discussed. 

8.1 Customizing print options 

 
One way to customize your plots is to adjust aspects regarding the appearance of your plot. 

These can be specified on the Print Settings tab. The follow plot properties regarding the way a graph 

is plotted can be specified: 

 

!! Note that some options are only available in one of the plotting standards 

 
� Overlap between adjacent pages 

� Cut off of qc signals (Dutch plot only) 

� Allow specified remarks to be printed on pages containing soil classification and IC plots 

� Colour or Black / White plot 

� Water level plotted 

� Showing the end values of signals at the end of the plot 

� Start level of the plot (ground or reference) 

� Plotting pre drill 

� Optional foot note (and alignment) printed at the bottom of each page 

� The granularity of the grid the graphs are plotted on 

� The colour of the gridlines 

� The vertical scale of the graph (Int. standard only) 

 

 
Customizing your plots 
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Besides plot related options a number of print paper related options can be specified: 

 

� The orientation of the plot (portrait / landscape (Int. standard only) ) 

� Paper size 

o A4 

o A3 

o Letter 

o Ledger 

o Height A3 / Width A4 (Dutch standard only) 

� X and Y Offset of the graph 

 

This screen also provides the option of storing a variety of derived signals in the eventual gef file. 

The signals that can be stored are all defined by the gef standard. 

 

Finally, the language in which the graph need to be plotted can be chosen. Here, a customized 

translation file can be selected ( see Chapter 9 ). 

 

!! Note that the plot language only translates the plots and not the application. 
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8.2 Customizing scale settings 

 
When plotting signals their horizontal scale can be manually adjusted. When no changes are made, 

CPTask uses default settings for these scales. By clicking on the “Scale” tab, all scales can be 

customized by specifying the range of the scale (requiring a min and a max value).  

 

 
Customizing the scales used in your plots. 

 

Once again, the adjusted scales can be propagated to all other opened files by clicking on the “Change 

for all open files” button on the bottom of the screen. 
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8.3 Customizing program settings and factors 

 
Besides customizing file dependant options, CPTask contains numerous application wide options 

which, once specified, apply to all files opened in CPTask. 

The Settings / Factors screen can be accessed by selecting the menu option: 

 

Settings → Settings / Factors 

 

Besides adjusting the various settings and factors, you can also save and load you customized settings 

for later use. This way you can easily switch between different settings. 

Saving and loading settings can be done by using the menu options: 

 

Settings → Save settings and Settings → Load settings respectively. 

8.3.1 Settings 

 
First of all the plotting standard as described in section 1.4 can be specified at the top of the screen. 

Several options regarding standard corrections and application wide parameter can be adjusted: 

 

� Shift of the fs signal 

� Default filter factor 

� Signals to filter 

� The company logo which is printed on each plot  (aspect ratio is preserved) 

� The currently active project directory 

� Overwriting sounding standards specified in the file 

 

 
Customizing your program settings 

 

When the inclination is known you can decide to correct the depth of the sounding according to the 

inclination. This adjusted depth can also be saved to file. Plots can be plotted according to the original 

depth or the adjusted depth. 
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!! Note When files are opened which don’t contains a inclination values, all signals are 

automatically plotted according to their original depth. 

 

Custom plot translation can be created using the “Custom translation creator” button. 

See chapter 9 for a detailed description of this feature. 

 

 

Finally the color schemes used for plotting the soil classification and the soil behavior index can be 

fully customized by clicking on the “Customize Soil / IC colors”. All colors can individually be 

adjusted. By using the “Restore default” button the original default values for that signal is reloaded. 

When exiting CPTask the specified color schemes are saved. 

 

 
Customizing your color schemes 
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8.3.2 Factors 

 
By selecting the “Factors” tab in the settings screen, you can adjust the constant factors used in the 

signal calculations. The formulas (in which these factors are used) can be found in Appendix A. 

 

 
Customizing factors for signal calculation 
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8.3.3 Language options 

 

Besides the language in which the graphs are plotted (see chapter 8.1), the language of CPTask itself 

can also be changed. By using the menu option: Language and selecting the desired language the 

application itself will be translated. 

 

Currently the following language are supported by CPTask: 

 

� English 

� Dutch 

� German 

 

!! Note that the application language and the plot language are independent of each other. 
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9 Customizing your plot language 
 
CPTask offers a simple way to customize the language used in your final plots.  

By using the “Custom translation creator” button in the option screen the translation creator screen is 

opened. By selecting the base translation file (containing the expressions to be translated, typically 

found in the …\CPTask\Custom Translations directory ) and specifying an output directory the custom 

translation file is set up. 

By providing a translation for each expressions a custom translation file can be compiled by using the 

“Compile” button. Note that translation of all expressions is mandatory. 

After providing a filename for the custom translation the a new compiler translation file is saved in the 

specified output directory. 

 

 
Creating a custom plot translation 

 

After a custom translation file is created, this file can be selected by using the “Custom” language 

option in the print settings screen of a specific sounding. 

 

!! We advise to create a special directory containing the customized translation files.
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Appendix A  Equations 

 
Depending on the measured parameters, the following equations are used to calculate derived signals. 

 

Signal Name Calculated by Unit 

Qc Cone resistance Measured parameter MPa 

Fs Local friction Measured parameter MPa 

Rf Friction ratio 
*100%

fs

qc
 

% 

I Inclination Measured parameter ° 

(1,2,3)U
 

Dynamic pore pressure Measured parameter MPa 

0u
 

Equilibrium pore pressure ρwater * (depth-waterlevel) MPa 

U / qc Dynamic pore pressure ration 2u

qc
 

- 

Qt Corrected cone resistance (1 ) * 2

0.81

qc s u

s

α

α

+ −

≈
 

MPa 

u∆  Excess pore pressure 2 0u u−  MPa 

Qe Effective cone resistance 2qt u−  MPa 

;v zσ  Total vertical stress dry wetγ γ+∑ ∑  kPa 

; 'v zσ  Effective vertical stress ; 0v z uσ −  kPa 

Qn Net cone resistance ; 'qt v zσ−  kPa 

Bq Pore pressure ratio u

qn

∆
 

- 

Qnorm Normalized cone resistance 

; '

qn

v zσ
 

- 

Fnorm Normalized local friction 
*100%

fs

qc
 

% 

Soil ID Soil classification Classification according to Robertson (1990) - 

Dr Relative density 

1

1
*

2 0* ; 'C
qc

LN
C C v zσ

 

Consolidated: C0 ≈ 157, C1 ≈ 0.55 

C2 ≈ 2.41 

Over-consolidated: C0 ≈ 181, 

C1 ≈ 0.55, C2 ≈ 2.61 

% 

Φ  Internal friction angle 
( * ( ))

; '

qc
ARCTAN a b LN

v zσ
+  

A ≈ 0.105, b ≈ 0.16 

° 

Su Undrained shear strength ;qc v z

Nk

σ−
 

Nk(min) ≈ 12, Nk(max) ≈ 20 

kPa 

Ic Soil behavior type index ( log ) (log )a qnorm fnorm b− + +  

A ≈ 3.47, b ≈ 1.22 

 

N60 Equivalent SPT N60 value 1
8.5*

4.6

qc Ic

pa

−  
  
  
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pa ≈ 100 

Qst Total friction Measured parameter kN 

Qt Total force Measured parameter kN 

Smp Soil Moisture Probe Measured parameter mS 

Ffd Fuel Fluorescence Detector Measured parameter mV 
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Appendix B  CPTask Menu Structure 

 


